It is currently Sun Feb 25, 2018 6:40 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Tue Feb 13, 2018 10:56 am 
Offline
Jackman
Jackman

Joined: Sat Oct 18, 2014 1:19 pm
Posts: 8
Hi Dave, thanks for making 3DSimED3.

Billboards in rFactor 2, I've noticed after exporting a track with 3dsimed the billboard trees bend over backwards if the camera gets to close to them in the game. They should only just rotate. It's like the Z axis is trying to face you as well not just the X and Y axis. It should be just the X and Y they rotate on.

How to test...
Load an unedited track into rF2, anyone will do, try a ISI/S397 one. Drive offroad through a group of billboard trees or billboard spectators. Notice they rotate to face you (as they should). Now load the same track into 3DSimED3 and export it. Now drive in the same place in rF2. You will now find the trees flip backwards as you get near them which is not right. If you look at the trees from under them, then the trees look down at you.

Don't know if this would be an easy fix or not for you? I would like to update the trees on Nords track but this is the only thing stopping me.

thanks again

DJC


Top
 Profile  
 
PostPosted: Sun Feb 18, 2018 4:27 am 
Offline
US Pits Crew
US Pits Crew

Joined: Thu Sep 01, 2005 9:58 am
Posts: 1367
Location: Barnet, London
Sorry for the delay in getting back but I have been away for a few days.

Please can you look at the pivot point for the tree because it needs to be bottom center. All three axis are rotated to face the viewer but using bottom center will stop the tree from apparently moving.

Cheers

Dave N.


Top
 Profile  
 
PostPosted: Sun Feb 18, 2018 10:50 am 
Offline
Jackman
Jackman

Joined: Sat Oct 18, 2014 1:19 pm
Posts: 8
Thanks for the reply, I hope you had a nice trip.

Yes, all the trees have pivot points bottom centre. Same for all tracks I test. They display perfectly in 3DsimEd, even ones that have been exported with it. In game they still pivot at the pivot points, it's just they face you on the Z axis too.

If it's helpful, I will try to make a video later.

cheers


Top
 Profile  
 
PostPosted: Sun Feb 18, 2018 2:29 pm 
Offline
Jackman
Jackman

Joined: Sat Oct 18, 2014 1:19 pm
Posts: 8
Here are 2 videos I made to try show problem a bit better. I just picked any track for this example, Spa.

This first video is before I did anything with 3DSimEd3. https://youtu.be/k9d4fWp54n4 . As you can see billboards are working fine.

This 2nd video is the same track loaded into 3DSimEd3, then I exported it to the same folder. I did not make any changes or edits. https://youtu.be/mPocom_jBU4.

As you can see the billboard people were falling over backward depending on where the camera is. Trees do the same.

It's a bit odd :D

DJC


Top
 Profile  
 
PostPosted: Tue Feb 20, 2018 5:58 am 
Offline
US Pits Crew
US Pits Crew

Joined: Thu Sep 01, 2005 9:58 am
Posts: 1367
Location: Barnet, London
I see what you mean!.

It's something that has changed in rF2 because when you use one of the old ISI rF2 viewers everything looks correct but with the latest Studio 397 viewers the axis are all wrong.

I will definitely try to fix this.

Cheers!

Dave N.


Top
 Profile  
 
PostPosted: Tue Feb 20, 2018 8:55 am 
Offline
Jackman
Jackman

Joined: Sat Oct 18, 2014 1:19 pm
Posts: 8
Thanks Dave, that would be great :) . Yes, it was easier to show in a video than trying to explain.

I can say it's not a new problem as I've had it some time now, reported also here> viewtopic.php?f=25&t=17146

Hope it's an easy fix. If you need me to test any test version just let me know.

thanks again.


Top
 Profile  
 
PostPosted: Wed Feb 21, 2018 4:52 am 
Offline
US Pits Crew
US Pits Crew

Joined: Thu Sep 01, 2005 9:58 am
Posts: 1367
Location: Barnet, London
Looks the same but I think that's a different problem. The one you reported is now fixed and will be in the next release.

Cheers

Dave N.


Top
 Profile  
 
PostPosted: Wed Feb 21, 2018 10:09 am 
Offline
Jackman
Jackman

Joined: Sat Oct 18, 2014 1:19 pm
Posts: 8
Thank you so very much. :)


Top
 Profile  
 
PostPosted: Thu Feb 22, 2018 2:09 pm 
Offline
Jackman
Jackman

Joined: Sat Oct 18, 2014 1:19 pm
Posts: 8
I've tested new version, and now the billboards work as normal. Thank you again. cheers


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group